Category Archives: Retrochallenge 2016/1

Retrochallenge 2016 – End of the line. All change.

Well, another RC comes to an end an if there’s any truth in the saying “It’s not the winning, it’s the taking apart” then all is well. If, however, it is the winning then we have another “success deficit” on our hands.

So far I have the VT-180 in pieces. I looked at a few signals on the video board and compared them to those marked on the schematic but they all looked fine (see the photos).

160116-IMG_20160116_181840 160116-IMG_20160116_181754 160116-IMG_20160116_181725So next up I wondered if the 2114 static RAM chips have failed. I’ve seen them go on my DEC Rainbow and also on a Commodore PET a friend of mine has, so it’s quite common really. It would explain the garbled output.

One thing I like about DEC kit is it’s well made. The downside is that they used a lot of solder and getting chips out of any DEC board I’ve ever worked on is very difficult. So, as the last few hours of RC2016-1 tick away I have3 chips out, new ones on order and crud to clean out of the holes in order to add sockets.

The nice thing about Retrochallenge is there’ll be another one passing by any minute now.

Retrochallenge 2016 – Week 1 done. Some progress.

So here we are, one week in to RC2016-01 and what do we have to show for it?

As you saw in my previous post, I have taken the lid off the VT180 and it sits as a bare metal cage while I try to figure out what’s wrong.

151231-IMG_20151231_174248The initial display (shown on the left) has changed and is less verbose. 160106-IMG_20160106_194827 I’m not sure what happened to trigger the change.

The screen display is no longer in sync and rolls very quickly.

In order to help with the repair I have taken the VT100 board out of the card cage and I have it plugged in to the cable that was powering the card edge connector on the card cage. It’s clearly straight through so should be fine.

160106-IMG_20160106_194705That means that I can get to the board with my meter and ‘scope etc. I have also removed the AVO (advanced Video Output) board and the small inter-connect board. This hasn’t changed the symptoms at all.

The first real diagnostic work was to measure the voltages from the PSU. They all seem fine.

I have been able to use a logic analyser (borrowed – I really want one of these) and I’ve been taking a look on the bus.

have attached three screen shots taken of the logic analyser screens. I have 18 channels and so I have the data bus, the lower 8 bits of the address bus and the synch pin. All signals are from clips on the 8080.

I have the triggers set to stable high on sync (start of new instruction) and 0 on the address bus. I put the analyser to wait for trigger and turned on the VT180.
The three shots are from the same run and I’ve just stepped through the time a little to show what happens at start up.

vt180-digiview-3vt180-digiview-2vt180-digiview-1I get this with or without the keyboard. With the keyboard, all of the lights are lit. When I first started on this repair, a few, normal looking lights came on first and then, after a while, they all came on. It’s a funny old world.

 

Retrochallenge 2016 – First look.

151231-IMG_20151231_174248Let’s start at the very beginning. It’s a very good place to start – Apparently.

According to the documentation, the VT180 is a VT100 serial terminal with a VT18X add on board. This add on is a Z80 single board computer that talks to the VT100 though one of its communications ports. this make for quite a nice combination for the day.

You can use the VT100 as just a terminal to your corporate mainframe or mini-computer and when required, fire up the Z80 into CP/M-80 and compute like there’s no tomorrow.

Mine is computing like Yesterday was a little rough.

Onward.

At this point I am working without the VT-18X board present. I don’t think I need it yet. My understanding is that the VT100 side should come up cleanly without it. I could of course be wrong but I’m going down this road for a while.

The photo above shows what I’m dealing with. The keyboard has sensible lights on but I don’t know yet if that means anything.

My first job as always is to try and re-seat all of the socketed chips on the board. I’ve don’t that and it made no difference. Oh well.

Going in.

Next step, are the voltages correct? The VT100 has an Intel 8080A processor on board and that needs care and feeding.

Off with its head.

One thing I’ve always liked about DEC equipment is the way they built it. Their kit always feels like it was ment to br built and stay together but they also kept in mind that you will need to service it.

160102-IMG_20160102_140931The photo on the left shows one of four plastic “poppers” that hold the case halves together. There are also four bolts to hold the steel frame in but that’s it. Dead easy.

160102-IMG_20160102_141849

Check the power supply.

Using the diagrams in MP00633_VT100_Schematic_Feb82.pdf I checked the voltages on all of the pins. Everything is OK with the exception of the 12V line. I can see that there should be 12V on the orange wire but there is hardly anything there at all 0.4V and just ain’t enough.

Is that my problem?

Hmmm. The CRT uses the same 12V supply and you can see from the top photo that the CRT is working. When I tested the voltages I didn’t have the CPU board in and the CRT didn’t come on. When I plug the CPU board in, the 12V comes back.

Doh! Red herring.

 

Retrochallenge 2016 – Setting up my stall.

On the eve of ‘challenge I have retrieved my VT-180 from the “shelf of good intentions”. I have taken photos of the two main boards and powered the machine up to see what happens.

151231-IMG_20151231_112224 151231-IMG_20151231_112314The first board basically the Z80 board. The second is a VT-100 terminal (if I remember correctly) and they talk to each other over the flat ribbon cable in the second photo.

Hmmm.

At the moment I don’t have the processor board in place as I think the VT side should come up without it. However, the current state of play is less than ideal.

151231-IMG_20151231_174248Roll on Tomorrow 🙂

 

Retrochallenge 2016. Step forward VT-180.

7ed07f63f5e5d6b2074f8a85a85c287eI was given this VT-180 machine a few years ago and after a quick look, I put it on the shelf to get round to later.

Retrochallenge 2016/1 is the later it’s been waiting for.

My aim this January is to mend this rather under rated but rather splendid CP/M-80 machine and get it to live, breathe and jump again.

Quick, to the Bat Cave.

Retrochallenge 2016 – Decisions decisions.

Retrochallenge 2016 will soon be upon us. This month long chance to dust off old kit and play about a bit is always great fun and a chance to get round to stuff I’ve wanted to have a crack at for ages.

Tradition dictates that I try in all earnestness to achieve something but I don’t hit my target. I’m not sure that it matters.

So, what to go for this time around? I’m not too sure yet. I certainly have a number of loose ends to tie up. I also have a whole load of new threads to pick at.

I quite like the idea of getting a SCSI/SD card adapter working on my PDP-11. I’ve got as far as plugging it in. Could January be its month?

Last month I found out about DEC’s T11 chip. This was

"a microprocessor that implements the PDP-11 instruction set architecture (ISA) developed by Digital Equipment Corporation. The T-11 was code-named "Tiny". It was developed for embedded systems and was the first single-chip microprocessor developed by DEC."

I’ve found a few designs for systems that use it, including DEC’s own development board, and I rather like the idea of building a small single board computer based on that design. A bit like the designs that Grant Searle as published for other retro processors.

Also, I promised myself that I’d spend some time on the DEC Robin AKA VT-180 CP/M machine that’s been on the shelf of “good intentions” for a few years now.

Oh well, still a few of weeks to choose before kick-off on Jan the 1st.  Wish me luck.